走迷宫-宽搜
给定一个n*m的二维整数数组,用来表示一个迷宫,数组中只包含0或1,其中0表示可以走的路,1表示不可通过的墙壁。
最初,有一个人位于左上角(1, 1)处,已知该人每次可以向上、下、左、右任意一个方向移动一个位置。
请问,该人从左上角移动至右下角(n, m)处,至少需要移动多少次。
数据保证(1, 1)处和(n, m)处的数字为0,且一定至少存在一条通路。
输入格式
第一行包含两个整数n和m。
接下来n行,每行包含m个整数(0或1),表示完整的二维数组迷宫。
输出格式
输出一个整数,表示从左上角移动至右下角的最少移动次数。
数据范围
$1≤n,m≤100$
输入样例:
5 5
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
输出样例:
8
代码
#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
typedef pair<int, int> PII;
const int N = 110;
int n, m;
int dx[4] = {-1,0,1,0}, dy[4] = {0,1,0,-1};
//距离矢量简化走法
int g[N][N], d[N][N];
//存储图+记录每个点到源点的距离
PII q[N*N], pre[N][N];
//记录当前队列中元素坐标,记录前置坐标方便标记路径
//自己实现队列模拟
int bfs1() {
int hh = 0, tt = 0;
q[0] = {0,0};
memset(d, -1, sizeof d);
d[0][0] = 0;
//宽搜套路
while(hh <= tt) {
auto t = q[hh++];
for(int i = 0; i < 4; i++) {
int x = t.first + dx[i], y = t.second + dy[i];
if(x>=0 && x<n && y>=0 && y<m && g[x][y]== 0 && d[x][y] == -1) {
d[x][y] = d[t.first][t.second] + 1;
pre[x][y] = t;
q[++tt] = {x,y};
}
}
}
int x = n - 1, y = m - 1;
while(x || y) {
cout << x << ' ' << y << endl;
auto t = pre[x][y];
x = t.first, y = t.second;
}
return d[n-1][m-1];
}
//调用queue
int bfs2() {
queue<PII> q;
memset(d, -1, sizeof d);
d[0][0] = 0;
q.push({0,0});
while(q.size()) {
auto t = q.front();
q.pop();
for(int i = 0; i < 4; i++) {
int x = t.first + dx[i], y = t.second + dy[i];
if(x>=0 && x < n && y>=0 && y < m && g[x][y] == 0 && d[x][y] == -1) {
d[x][y] = d[t.first][t.second] + 1;
q.push({x, y});
}
}
}
return d[n-1][m-1];
}
int main() {
cin >> n >> m;
for(int i = 0; i < n; i++)
for(int j = 0; j < m; j++)
cin >> g[i][j];
//cout << bfs1() << endl;
cout << bfs2() << endl;
return 0;
}