题目描述
单词接龙是一个与我们经常玩的成语接龙相类似的游戏。
现在我们已知一组单词,且给定一个开头的字母,要求出以这个字母开头的最长的“龙”,每个单词最多被使用两次。
在两个单词相连时,其重合部分合为一部分,例如 beast 和 astonish ,如果接成一条龙则变为 beastonish。
我们可以任意选择重合部分的长度,但其长度必须大于等于1,且严格小于两个串的长度,例如 at 和 atide 间不能相连。
输入格式
输入的第一行为一个单独的整数 n 表示单词数,以下 n 行每行有一个单词(只含有大写或小写字母,长度不超过20),输入的最后一行为一个单个字符,表示“龙”开头的字母。
你可以假定以此字母开头的“龙”一定存在。
输出格式
只需输出以此字母开头的最长的“龙”的长度。
数据范围
n≤20
输入样例:
5
at
touch
cheat
choose
tact
a
输出样例:
23
提示
连成的“龙”为 atoucheatactactouchoose。
算法 dfs O(?)
把每个字符串可达的另一个字符串用邻接表存起来,然后跑DFS就可以了~。~
#include <iostream>
#include <string>
#include <algorithm>
#include <vector>
#include <cstring>
using namespace std;
const int N = 25;
vector<int> ver[N],edge[N];//匹配的单词编号和匹配长度
string word[N];
int n,res;
int st[N];
void dfs(string u,int k)
{
st[k] ++;
res = max(res,(int)u.size());
for(int i=0;i<ver[k].size();i++)
{
int p=ver[k][i],d=edge[k][i];
if(st[p]<2)
dfs(u+word[p].substr(d),p);
}
st[k] --;
}
int main(){
//freopen("data.in","r",stdin);
//freopen("data.out","w",stdout);
cin >> n;
for(int i=1;i<=n;i++)
cin >> word[i];
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
{
string a = word[i] , b = word[j];
int len = min(a.size(),b.size());
for(int k=1;k<len;k++)
{
if(a.substr(a.size()-k)==b.substr(0,k))
{
ver[i].push_back(j);
edge[i].push_back(k);
break;
}
}
}
string s;
cin >> s;
for(int i=1;i<=n;i++)
if(s[0]==word[i][0])
dfs(word[i],i);
cout << res << endl;
return 0;
}