题目描述
给定一个包含 n 个点(编号为 1∼n)的无向图,初始时图中没有边。
现在要进行 m 个操作,操作共有三种:
C a b,在点 a 和点 b 之间连一条边,a 和 b 可能相等;
Q1 a b,询问点 a 和点 b 是否在同一个连通块中,a 和 b 可能相等;
Q2 a,询问点 a 所在连通块中点的数量;
输入格式
第一行输入整数 n 和 m。
接下来 m 行,每行包含一个操作指令,指令为 C a b,Q1 a b 或 Q2 a 中的一种。
输出格式
对于每个询问指令 Q1 a b,如果 a 和 b 在同一个连通块中,则输出 Yes,否则输出 No。
对于每个询问指令 Q2 a,输出一个整数表示点 a 所在连通块中点的数量
每个结果占一行。
数据范围
1≤n,m≤1e5
输入样例:
5 5
C 1 2
Q1 1 2
Q2 1
C 2 5
Q2 5
输出样例:
Yes
2
3
算法1
#include<iostream>
using namespace std;
const int N=100010;
int p[N],sizes[N];
int find(int x)
{
if(p[x]!=x) p[x]=find(p[x]);
return p[x];
}
int main()
{
int n,m;
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)
{
p[i]=i;
sizes[i]=1;//谨保证根节点的sizes有意义即可
}
int a,b;
char op[3];
while(m--)
{
scanf("%s",op);
if(op[0]=='C')
{
scanf("%d%d",&a,&b);
//if(find(a)==find(b)) continue;//或者if(find(a)!=find(b))
if(find(a)!=find(b))
{
sizes[find(b)]+=sizes[find(a)];//! 注意与下句话顺序不能颠倒!
p[find(a)]=find(b);//先计数后合并连接两集合
}
}
else if(op[1]=='1')
{
scanf("%d%d",&a,&b);
if(find(a)==find(b)) printf("Yes\n");
else printf("No\n");
}
else
{
scanf("%d",&a);
printf("%d\n",sizes[find(a)]);//返回a的根节点的sizes即可
}
}
return 0;
}
算法2
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
/**
* Created by Yolanda on 2021/6/2 21:43
*/
public class Main {
static int N=100010;
static int[] p=new int[N];
static int[] sizes=new int[N];
static int find(int x)
{
if(p[x]!=x)
{
p[x]=find(p[x]);
}
return p[x];
}
public static void main(String[] args) throws IOException {
BufferedReader br=new BufferedReader(new InputStreamReader(System.in));
int n,m;
String[] s=br.readLine().split(" ");
n=Integer.parseInt(s[0]);
m=Integer.parseInt(s[1]);
for (int i = 1; i <=n; i++) {
p[i]=i;
sizes[i]=1;
}
int a,b;
while (m-->0)
{
String[] ss=br.readLine().split(" ");
String op=ss[0];
if(op.equals("C"))
{
a=Integer.parseInt(ss[1]);
b=Integer.parseInt(ss[2]);
if(find(a)!=find(b))
{
sizes[find(b)]+=sizes[find(a)];
p[find(a)]=find(b);
}
}
else if(op.equals("Q1"))
{
a=Integer.parseInt(ss[1]);
b=Integer.parseInt(ss[2]);
if(find(a)==find(b)) System.out.println("Yes");
else System.out.println("No");
}
else
{
a=Integer.parseInt(ss[1]);
System.out.println(sizes[find(a)]);
}
}
}
}