解法1:gcc支持__int128,直接暴力做
题目描述
求 a 乘 b 对 p 取模的值。
输入格式
第一行输入整数a,第二行输入整数b,第三行输入整数p。
输出格式
输出一个整数,表示a*b mod p的值。
数据范围
1≤a,b,p≤1018
输入样例:
3
4
5
输出样例:
2
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
typedef unsigned long long LL;
LL a, b, p;
int main()
{
cin >> a >> b >> p;
__int128 _a = a, _b = b; //两个_下划线!!!
LL res = _a * _b % p;
cout << res << endl;
return 0;
}
算法2
用快速幂思想做
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
typedef unsigned long long LL;
LL a, b, p;
int main()
{
cin >> a >> b >> p;
LL res = 0;
while(b)
{
if(b & 1) res = (res + a) % p;
b >>= 1;
a = a * 2 % p;
}
cout << res % p << endl;
return 0;
}