题目描述
有一间长方形的房子,地上铺了红色、黑色两种颜色的正方形瓷砖。
你站在其中一块黑色的瓷砖上,只能向相邻(上下左右四个方向)的黑色瓷砖移动。
请写一个程序,计算你总共能够到达多少块黑色的瓷砖。
输入格式
输入包括多个数据集合。
每个数据集合的第一行是两个整数 W 和 H,分别表示 x 方向和 y 方向瓷砖的数量。
在接下来的 H 行中,每行包括 W 个字符。每个字符表示一块瓷砖的颜色,规则如下
1)‘.’:黑色的瓷砖;
2)‘#’:红色的瓷砖;
3)‘@’:黑色的瓷砖,并且你站在这块瓷砖上。该字符在每个数据集合中唯一出现一次。
当在一行中读入的是两个零时,表示输入结束。
输出格式
对每个数据集合,分别输出一行,显示你从初始位置出发能到达的瓷砖数(记数时包括初始位置的瓷砖)。
数据范围
1≤W,H≤20
样例
输入样例:
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
0 0
输出样例:
45
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main(){
char input[30][30];
int bfs[1000][2], w, h, ans, ind, tind, dx[4] = {0,0,-1,1}, dy[4] = {1,-1,0,0};
while(true){
ans = ind = tind = 0;
scanf("%d%d", &w, &h);
if(w == 0 && h == 0) break;
for(int i = 0; i < h; i++){
scanf("%s", input[i]);
for(int j = 0; j < w && !ind; j++){
if(input[i][j] == '@'){
bfs[ind][0] = i;
bfs[ind++][1] = j;
input[i][j] = '#';
ans++;
}
}
}
while(tind < ind){
for(int i = 0; i < 4; i++){
int xx = bfs[tind][0] + dx[i], yy = bfs[tind][1] + dy[i];
if(xx >= 0 && xx < h && yy >= 0 && yy < w && input[xx][yy] == '.'){
bfs[ind][0] = xx;
bfs[ind++][1] = yy;
input[xx][yy] = '#';
ans++;
}
}
tind++;
}
printf("%d\n", ans);
}
return 0;
}