题目描述
从 1∼n 这 n 个整数中随机选取任意多个,输出所有可能的选择方案。
输入格式
输入一个整数 n。
输出格式
每行输出一种方案。
同一行内的数必须升序排列,相邻两个数用恰好 1 个空格隔开。
对于没有选任何数的方案,输出空行。
本题有自定义校验器(SPJ),各行(不同方案)之间的顺序任意。
数据范围
1≤n≤15
样例
输入样例:
3
输出样例:
3
2
2 3
1
1 3
1 2
1 2 3
#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
const int N = 16;
int n;
bool sign[N]; // false不选,true选
void dfs(int t){
if(t > n){
for(int i = 1; i <= n; i++)
if(sign[i]) printf("%d ", i);
printf("\n");
return;
}
dfs(t+1);
sign[t] = 1;
dfs(t+1);
sign[t] = 0;
}
int main(){
cin >>n;
dfs(1);
return 0;
}