题目描述
给定一个 n×m 的二维整数数组,用来表示一个迷宫,数组中只包含 0 或 1,其中 0 表示可以走的路,1 表示不可通过的墙壁。
最初,有一个人位于左上角 (1,1) 处,已知该人每次可以向上、下、左、右任意一个方向移动一个位置。
请问,该人从左上角移动至右下角 (n,m) 处,至少需要移动多少次。
数据保证 (1,1) 处和 (n,m) 处的数字为 0,且一定至少存在一条通路。
输入格式
第一行包含两个整数 n 和 m。
接下来 n 行,每行包含 m 个整数(0 或 1),表示完整的二维数组迷宫。
输出格式
输出一个整数,表示从左上角移动至右下角的最少移动次数。
样例
数据范围
1≤n,m≤100
输入样例:
5 5
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
输出样例:
8
算法1
(bfs) $O(n^2)$
C++ 代码
#include <iostream>
#include <vector>
#include <queue>
using namespace std;
vector<vector<int>> steps;
queue<pair<int,int>> q;
int n = 0, m = 0;
void bfs(vector<vector<int>> &table){
int dx[4] = {-1, 1, 0, 0}, dy[4] = {0, 0, -1, 1};
q.push({0, 0}); //将第一个坐标填入。
steps[0][0] = 0;
while(q.size()){
auto tmp = q.front();
q.pop();
for(int i = 0; i < 4; ++i){
int x = tmp.first + dx[i], y = tmp.second + dy[i];
// cout<<"test"<<endl;
if(x >=0 && x < n && y >= 0 && y < m && table[x][y] == 0 && steps[x][y] == -1){
steps[x][y] = steps[tmp.first][tmp.second] + 1;
// cout<<steps[x][y];
q.push({x, y}); //将符合条件的坐标加入
}
}
}
}
int main(){
cin>>n>>m;
vector<vector<int>> table(n, vector<int>(m,0));
for(int i = 0; i < n; ++i){
for(int j = 0; j < m; ++j){
cin>>table[i][j];
// cout<<table[i][j]<<" ";
}
// cout<<endl;
}
steps = vector<vector<int>>(n, vector<int>(m,-1));
bfs(table);
cout<<steps[n - 1][m - 1];
return 0;
}