题目描述
n− 皇后问题是指将 n 个皇后放在 n×n 的国际象棋棋盘上,使得皇后不能相互攻击到,即任意两个皇后都不能处于同一行、同一列或同一斜线上。
现在给定整数 n,请你输出所有的满足条件的棋子摆法。
输入格式
共一行,包含整数 n。
输出格式
每个解决方案占 n 行,每行输出一个长度为 n 的字符串,用来表示完整的棋盘状态。
其中 . 表示某一个位置的方格状态为空,Q 表示某一个位置的方格上摆着皇后。
每个方案输出完成后,输出一个空行。
注意:行末不能有多余空格。
输出方案的顺序任意,只要不重复且没有遗漏即可。
样例
数据范围
1≤n≤9
输入样例:
4
输出样例:
.Q..
...Q
Q...
..Q.
..Q.
Q...
...Q
.Q..
算法1
(暴力枚举) $O(n*n!)$
C++ 代码
#include <iostream>
#include <vector>
using namespace std;
int n;
vector<bool> up, down, col;
vector<vector<char>> table;
void dfs(int u){
if(u == n){
for(int i = 0; i < n; ++i){
for(int j = 0; j < n; ++j){
cout<<table[i][j];
}
cout<<endl;
}
cout<<endl;
return;
}
//枚举每一行的每一个位置
for(int j = 0; j < n; ++j){
if(!col[j] && !up[u + j] && !down[u - j + n]){
table[u][j] = 'Q';
col[j] = up[u + j] = down[u - j + n] = true;
dfs(u + 1);
col[j] = up[u + j] = down[u - j + n] = false;
table[u][j] = '.';
}
}
}
int main(){
cin>>n;
col = vector<bool>(n, false);
down = vector<bool>(2*n, false);
up = vector<bool>(2*n, false);
table = vector<vector<char>>(n, vector(n, '.'));
//dfs每一行
dfs(0);
return 0;
}
直接将状态用map存
#include <iostream>
#include <vector>
#include <unordered_map>
using namespace std;
int n;
unordered_map<int, bool> up, down, col;
vector<vector<char>> table;
void dfs(int u){
if(u == n){
for(int i = 0; i < n; ++i){
for(int j = 0; j < n; ++j){
cout<<table[i][j];
}
cout<<endl;
}
cout<<endl;
return;
}
//枚举每一行的每一个位置
for(int j = 0; j < n; ++j){
if(!col[j] && !up[u + j] && !down[u - j]){
table[u][j] = 'Q';
col[j] = up[u + j] = down[u - j] = true;
dfs(u + 1);
col[j] = up[u + j] = down[u - j] = false;
table[u][j] = '.';
}
}
}
int main(){
cin>>n;
table = vector<vector<char>>(n, vector(n, '.'));
//dfs每一行
dfs(0);
return 0;
}
o(2^(n^2))
#include <iostream>
#include <unordered_map>
using namespace std;
const int N = 10;
int n;
bool row[N], col[N], up[N * 2], down[N * 2];
char g[N][N];
void dfs(int x, int y, int s){
if(y == n){
y = 0;
++x;
}
if(x == n){
if(s == n){
for (int i = 0; i < n; i ++ ) puts(g[i]);
puts("");
}
return;
}
if(x > n) return;
//不放皇后
dfs(x, y + 1, s);
//放皇后
if(!row[x] && !col[y] && !up[x + y] && !down[x - y + n]){
g[x][y] = 'Q';
row[x] = col[y] = up[x + y] = down[x - y + n] = true;
dfs(x, y + 1, s + 1);
g[x][y] = '.';
row[x] = col[y] = up[x + y] = down[x - y + n] = false;
}
}
int main(){
cin>>n;
for(int i = 0; i < n; ++i){
for(int j = 0; j < n; ++j){
g[i][j] = '.';
}
}
//dfs每一个位置
dfs(0,0,0);
return 0;
}