题目描述
一次生日Party可能有p人或者q人参加,现准备有一个大蛋糕.问最少要将蛋糕切成多少块(每块大小不一定相等),才能使p人或者q人出席的任何一种情况,都能平均将蛋糕分食.
Input
每行有两个数p和q.(多样例)
Output
输出最少要将蛋糕切成多少块.
样例
Sample Input
2 3
Sample Output
4
p,q
先把蛋糕分成p份,需要切p刀,把蛋糕分成q份,就需要切q刀,但是会有重复的部分,重复的部分是gcd(p,q)
即:p + q - gcd(p,q)
#include <iostream>
#include <cstring>
using namespace std;
int gcd(int a,int b){
if(b==0) return a;
else return gcd(b,a%b);
}
int main(int argc, char** argv) {
int a,b;
while(scanf("%d%d",&a,&b)!=EOF){
printf("%d\n",a+b-gcd(a,b));
}
return 0;
}