题目描述
Ray又对数字的列产生了兴趣:
现有四张卡片,用这四张卡片能排列出很多不同的4位数,要求按从小到大的顺序输出这些4位数。
Input
每组数据占一行,代表四张卡片上的数字(0<=数字<=9),如果四张卡片都是0,则输入结束。
Output
对每组卡片按从小到大的顺序输出所有能由这四张卡片组成的4位数,千位数字相同的在同一行,同一行中每个四位数间用空格分隔。
每组输出数据间空一行,最后一组数据后面没有空行。
样例
Sample Input
1 2 3 4
1 1 2 3
0 1 2 3
0 0 0 0
Sample Output
1234 1243 1324 1342 1423 1432
2134 2143 2314 2341 2413 2431
3124 3142 3214 3241 3412 3421
4123 4132 4213 4231 4312 4321
1123 1132 1213 1231 1312 1321
2113 2131 2311
3112 3121 3211
1023 1032 1203 1230 1302 1320
2013 2031 2103 2130 2301 2310
3012 3021 3102 3120 3201 3210
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int a[5];
int main(int argc, char** argv) {
int tag=0;
while(cin>>a[1]>>a[2]>>a[3]>>a[4]){
if(a[1]==0&&a[2]==0&&a[3]==0&&a[4]==0) break;
sort(a+1,a+5);
if(tag) cout<<endl;
tag=1;
int flag=1;
int tmp;
do{
if(a[1]==0) continue;
if(flag){
cout<<a[1]<<a[2]<<a[3]<<a[4];
flag=0;
}
else if(a[1]==tmp){
cout<<" "<<a[1]<<a[2]<<a[3]<<a[4];
}
else {
cout<<endl<<a[1]<<a[2]<<a[3]<<a[4];
}
tmp=a[1];
}while(next_permutation(a+1,a+5));
cout<<endl;
}
return 0;
}
拓展全排列模板:
整型的
int a[3]={3,1,2};
sort(a,a+3);//从小到大排序,这样可以打印出所有数的全排列
do
{
for(int i=0;i<3;i++)
cout<<a[i]<<" ";
cout<<endl;
}while(next_permutation(a,a+3));//这个函数需要头文件#include<algorithm>
字符型的
char ch[1000];
cin>>ch;
int len=strlen(ch);
sort(ch,ch+len);
do{
cout<<ch<<endl;
}while(next_permutation(ch,ch+len));//这个函数需要头文件#include<algorithm>
手写的全排列函数,这个代码仅仅适用于四位不同的数字进行全排列,不可以有重复的数字,它过不了本题,作为练习拓展吧
#include<bits/stdc++.h>
#include <iostream>
using namespace std;
#include <cstdio>
int n;
int a[10];
int flag;
int order[10];//表示此数的值
bool st[10];//表示此数是否被使用过
void dfs(int x){//枚举第x个位置
int tmp;
if(x>4){
if(order[1]==0) return;
if(flag) flag=0;
else if(order[1]==tmp){
printf(" ");
}
else{
printf("\n");
}
tmp=order[1];
for(int i=1;i<=4;i++){
printf("%d",order[i]);
}
printf(" ");
return;
}
else{
for(int i=1;i<=4;i++){
if(st[a[i]]) continue;
st[a[i]]=1;
order[x]=a[i];//注意是第x个位置上的数是i
dfs(x+1);
st[a[i]]=0;//恢复现场
order[x]=0;//恢复现场,可省略
}
}
}
int main() {
int tag=0;
while(cin>>a[1]>>a[2]>>a[3]>>a[4]){
if(a[1]==0&&a[2]==0&&a[3]==0&&a[4]==0) continue;
if(tag) cout<<endl;
tag=1;
flag=1;
dfs(1);
cout<<endl;
}
return 0;
}