题目描述
小蓝给学生们组织了一场考试,卷面总分为 100 分,每个学生的得分都是一个 0 到 100 的整数。
如果得分至少是 60 分,则称为及格。
如果得分至少为 85 分,则称为优秀。
请计算及格率和优秀率,用百分数表示,百分号前的部分四舍五入保留整数。
输入格式
输入的第一行包含一个整数 n,表示考试人数。
接下来 n 行,每行包含一个 0 至 100 的整数,表示一个学生的得分。
输出格式
输出两行,每行一个百分数,分别表示及格率和优秀率。
百分号前的部分四舍五入保留整数。
样例
输入样例:
7
80
92
56
74
88
100
0
输出样例:
71%
43%
C++ 代码
#include <iostream>
#include <math.h>
using namespace std;
int main()
{
int n;
cin>>n;
int acount=0;
int bcount=0;
for(int i=0;i<n;i++){
int score=0;
cin>>score;
if(score>=60) bcount++;
if(score>=85) acount++;
}
float a=floor(((acount*1.0)/n)*100+0.5); //注意四舍五入写法
float b=floor(((bcount*1.0)/n)*100+0.5);
cout<<b<<"%"<<endl<<a<<"%"<<endl;
}