天梯赛L2-048 寻宝图(bfs)
思路:遍历数组找到不为0的位置bfs,重复进行即可。注意一点读入是字符串。
给定一幅地图,其中有水域,有陆地。被水域完全环绕的陆地是岛屿。有些岛屿上埋藏有宝藏,这些有宝藏的点也被标记出来了。本题就请你统计一下,给定的地图上一共有多少岛屿,其中有多少是有宝藏的岛屿。
输入格式:
输入第一行给出 2 个正整数 N 和 M(1<N×M≤10
5
),是地图的尺寸,表示地图由 N 行 M 列格子构成。随后 N 行,每行给出 M 位个位数,其中 0 表示水域,1 表示陆地,2-9 表示宝藏。
注意:两个格子共享一条边时,才是“相邻”的。宝藏都埋在陆地上。默认地图外围全是水域。
输出格式:
在一行中输出 2 个整数,分别是岛屿的总数量和有宝藏的岛屿的数量。
输入样例:
10 11
01000000151
11000000111
00110000811
00110100010
00000000000
00000111000
00114111000
00110010000
00019000010
00120000001
输出样例:
7 2
#include <bits/stdc++.h>
using namespace std;
const int N = 1005; // 适用于 N×M <= 10^5 的情况
vector<vector<int>> a, st;
int dx[4] = {-1, 1, 0, 0};
int dy[4] = {0, 0, -1, 1};
int n, m;
int resd = 0, resb = 0;
void bfs(int x, int y) {
queue<pair<int, int>> q;
q.push({x, y});
st[x][y] = 1;
bool hasTreasure = false; // 标记是否有宝藏
while (!q.empty()) {
auto [cx, cy] = q.front();
q.pop();
if (a[cx][cy] > 1) hasTreasure = true; // 发现宝藏
for (int i = 0; i < 4; i++) {
int xx = cx + dx[i], yy = cy + dy[i];
if (xx >= 0 && xx < n && yy >= 0 && yy < m && a[xx][yy] >= 1 && !st[xx][yy]) {
st[xx][yy] = 1;
q.push({xx, yy});
}
}
}
resd++; // 发现一个新的岛屿
if (hasTreasure) resb++; // 该岛屿包含宝藏
}
int main() {
cin >> n >> m;
// 初始化地图和标记数组
a.resize(n, vector<int>(m, 0));
st.resize(n, vector<int>(m, 0));
for (int i = 0; i < n; i++) {
string row;
cin >> row;
for (int j = 0; j < m; j++) {
a[i][j] = row[j] - '0';
}
}
// 遍历地图,找到所有岛屿
for (int i = 0; i < n; i++) {
for (int j = 0; j < m; j++) {
if (a[i][j] >= 1 && !st[i][j]) {
bfs(i, j);
}
}
}
cout << resd << " " << resb << endl;
return 0;
}