单词接龙是一个与我们经常玩的成语接龙相类似的游戏。
现在我们已知一组单词,且给定一个开头的字母,要求出以这个字母开头的最长的“龙”,每个单词最多被使用两次。
在两个单词相连时,其重合部分合为一部分,例如 beast 和 astonish ,如果接成一条龙则变为 beastonish。
我们可以任意选择重合部分的长度,但其长度必须大于等于1,且严格小于两个串的长度,例如 at 和 atide 间不能相连。
输入格式
输入的第一行为一个单独的整数 $n$ 表示单词数,以下 $n$ 行每行有一个单词(只含有大写或小写字母,长度不超过20),输入的最后一行为一个单个字符,表示“龙”开头的字母。
你可以假定以此字母开头的“龙”一定存在。
输出格式
只需输出以此字母开头的最长的“龙”的长度。
数据范围
$n \le 20$,
单词随机生成。
输入样例:
5
at
touch
cheat
choose
tact
a
输出样例:
23
提示
连成的“龙”为 atoucheatactactouchoose。
#include <cstring>
#include <iostream>
using namespace std;
const int N = 25;
int n, ans;
string s[N];
int st[N];
void dfs(string x, int y)
{
st[y] ++;
int len = x.size();
ans = max(ans, len);
string t;
for (int i = 0; i < n; i ++)
for (int j = len - 1, k = 1; j > 0 && k < s[i].size(); j --, k ++)
if (st[i] < 2 && x.substr(j) == s[i].substr(0, k))
{
t = x.substr(0, len - k) + s[i];
dfs(t, i);
}
st[y] --;
}
int main()
{
cin >> n;
for (int i = 0; i < n; i ++) cin >> s[i];
string start;
cin >> start;
start = " " + start;
dfs(start, n);
cout << ans - 1;
return 0;
}