题目描述
给定一个n个点m条边的有向图,图中可能存在重边和自环,所有边权均为非负值。
请你求出1号点到n号点的最短距离,如果无法从1号点走到n号点,则输出-1。
输入格式
第一行包含整数n和m。
接下来m行每行包含三个整数x,y,z,表示存在一条从点x到点y的有向边,边长为z。
输出格式
输出一个整数,表示1号点到n号点的最短距离。
如果路径不存在,则输出-1。
数据范围
1≤n,m≤105,
图中涉及边长均不小于0,且不超过10000。
样例
输入样例:
3 3
1 2 2
2 3 1
1 3 4
输出样例:
3
Dijkstra(邻接表 + 优先队列)
刚开始也不是太懂,手动推导一遍理解的比较深。
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
typedef pair<int, int> PII;
const int N = 100010;
bool st[N];
int n, m;
int e[N], w[N], ne[N], h[N], idx;
//e[i]表示邻边的另一个端点,w[i]表示邻边长度,ne[i]表示链表下一节点下标,idx表示当前用到了哪个下标
int dist[N];
void add(int a, int b, int c)//插入元素
{//w[i]存 边值
e[idx] = b, w[idx] = c, ne[idx] = h[a], h[a] = idx ++ ;
}
int di()
{
memset(dist, 0x3f, sizeof dist);
dist[1] = 0;//这一步可以不要
priority_queue<PII, vector<PII>, greater<PII>> heap;//从小到大排序
heap.push({0, 1});//{距离, 第几个点}
while(heap.size())
{
PII t = heap.top();//取队头元素
heap.pop();//弹出队列
int ver = t.second, distance = t.first;
if(st[ver]) continue;
st[ver] = true;
for(int i = h[ver]; i != -1; i = ne[i])
{
int j = e[i];
if(dist[j] > distance + w[i])
{
dist[j] = distance + w[i];//更新距离
heap.push({dist[j], j});
}
}
}
if(dist[n] == 0x3f3f3f3f) return -1;
return dist[n];
}
int main()
{
cin >> n >> m;
memset(h, -1, sizeof h);
while(m -- )
{
int a, b, c;
cin >> a >> b >> c;
add(a, b, c);
}
cout << di() << endl;
return 0;
}