题目描述
给定一个长度为N的整数数列,输出每个数左边第一个比它小的数,如果不存在则输出-1。
输入格式
第一行包含整数N,表示数列长度。
第二行包含N个整数,表示整数数列。
输出格式
共一行,包含N个整数,其中第i个数表示第i个数的左边第一个比它小的数,如果不存在则输出-1。
数据范围
1≤N≤105
1≤数列中元素≤109
样例
输入样例:
5
3 4 2 7 5
输出样例:
-1 3 -1 2 2
算法1
(模拟)
C++ 代码
#include<iostream>
using namespace std;
const int N=100010;
int s[N],tt;
int n;
int main(){
cin>>n;
for(int i=0;i<n;i++)
{
int x;
cin>>x;
while(tt&&s[tt]>=x)tt--;
if(tt)cout<<s[tt]<<" ";
else cout<<"-1"<<" ";
s[++tt]=x;
}
return 0;
}
算法2
(STL) $O(n)$
C++ 代码
#include<iostream>
#include<vector>
#include<stack>
using namespace std;
const int N=100010;
int n;
int a[N];
stack<int>stk;
int main() {
cin.tie(0);
ios::sync_with_stdio(false);
cin >> n;
for (int i = 0; i < n; ++i) {
int s; cin >> s;
while (!stk.empty() && s <= stk.top())stk.pop();
a[i] = stk.empty() ? -1 : stk.top();
stk.push(s);
}
for (int i=0;i<n;i++)cout <<a[i]<< " ";
cout << endl;
return 0;
}
这里s[0]是一直没有进行赋值吗?
确实
# ganxie
没有一起学习