用二维数组!
输入样例
Hello World Here I Come
输出样例
Come I Here World Hello
#include <math.h>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
typedef long long LL;
const int N = 110;
int main( ) {
char a[90][90];
int num = 0;
while ( scanf("%s", a[num]) != EOF ) num++;
for ( int i = num-1; i >=0; i -- ) {
printf("%s", a[i] );
if ( i > 0 ) printf(" ");
}
return 0;
}