一个正整数 N 的因子中可能存在若干连续的数字。例如 630 可以分解为 3×5×6×7,其中 5、6、7 就是 3 个连续的数字。给定任一正整数 N,要求编写程序求出最长连续因子的个数,并输出最小的连续因子序列。
输入格式:
输入在一行中给出一个正整数 N(1<N<2^31)。
输出格式:
首先在第 1 行输出最长连续因子的个数;然后在第 2 行中按 因子1因子2……*因子k 的格式输出最小的连续因子序列,其中因子按递增顺序输出,1 不算在内。
输入样例:
630
输出样例:
3
5*6*7
#include<bits/stdc++.h>
using namespace std;
int n;
vector<int> fenjie( ){
vector<int> ans;
for(int i = 2; i <= n/i; i++){
int nn = n;
int j = i;
vector<int> res;
while(nn % j == 0){
res.push_back(j);
nn /= j;
j++;
}
if(res.size() > ans.size()){
ans = res;
}
}
if(ans.empty())
ans.push_back(n);
return ans;
}
int main(){
cin>>n;
vector<int> ans = fenjie();
cout<<ans.size()<<endl;
for(int i = 0;i < ans.size();i++){
if(i) cout<<"*";
cout<<ans[i];
}
return 0;
}