本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:
无论用户说什么,首先把对方说的话在一行中原样打印出来;
消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
把原文中所有大写英文字母变成小写,除了 I;
把原文中所有独立的 can you、could you 对应地换成 I can、I could—— 这里“独立”是指被空格或标点符号分隔开的单词;
把原文中所有独立的 I 和 me 换成 you;
把原文中所有的问号 ? 换成惊叹号 !;
在一行中输出替换后的句子作为 AI 的回答。
输入格式:
输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。
输出格式:
按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。
输入样例:
6
Hello ?
Good to chat with you
can you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don ‘t know
输出样例:
Hello ?
AI: hello!
Good to chat with you
AI: good to chat with you
can you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don ‘t know
AI: what Is this prime! you,don’t know
#include<bits/stdc++.h>
using namespace std;
int judge(char c){
if (c >= 'A'&&c <= 'Z') return 1;
if (c >= 'a'&&c <= 'z') return 2;
if (c >= '0'&&c <= '9') return 3;
if (c == ' ') return -1;
return 0;
}
int main(){
int n;
cin>>n;
cin.ignore();
while(n--){
string s;
getline(cin,s);
cout<<s<<endl;
stringstream ss(s);
string t;
ss>>t;
s = t;
while(ss>>t){
if(judge(t[0]) != 0)
s += " ";
s += t;
}
for(int i = 0;i < s.size();i++){
if(s[i] == '?') s[i] = '!';
if(s[i] != 'I') s[i] = tolower(s[i]);
}
s = " " + s;
string str = "";
for(int i = 0;i < s.size(); ){
if(judge(s[i])<=0){
if(i != 0)
{
str += s[i];
}
if( ((i + 7) < s.size() && s.substr(i+1,7) == "can you") && ( (i + 8 == s.size()) || judge(s[i + 8]) <= 0))
{
str += "I can";
i += 8;
}else if(((i + 9) < s.size() && s.substr(i+1,9) == "could you") && ((i + 10 == s.size()) || judge(s[i + 10])<=0))
{
str += "I could";
i += 10;
}else if((i+1) < s.size() && s.substr(i+1,1) == "I" && ((i + 2 == s.size()) || judge(s[i + 2])<=0))
{
str += "you";
i += 2;
}else if((i + 2) < s.size() && s.substr(i+1,2) == "me" && ((i + 3 == s.size()) || judge(s[i + 3])<=0))
{
str += "you";
i += 3;
}else{
size_t pos = s.find(" ",i+1);
if(pos != string:: npos){
string sr = s.substr(i+1,pos - i-1);
str += sr;
i = pos;
}else{
string sr = s.substr(i+1);
str += sr;
i = s.size();
}
}
}
}
cout<<"AI: "<<str<<endl;
}
return 0;
}