题目描述
给定一个整数 n,将数字 1∼n排成一排,将会有很多种排列方法。
现在,请你按照字典序将所有的排列方法输出。
输入样例:
3
输出样例:
1 2 3
1 3 2
2 1 3
2 3 1
3 1 2
3 2 1
import java.io.*;
public class Main {
static int n;
static boolean[] used;
static int[] res;
public static void main(String[] args) throws IOException{
StreamTokenizer re=new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));
re.nextToken();n=(int)re.nval;
used=new boolean[n+1];
res=new int[n+1];
dfs(0);
}
static void dfs(int u){
if(u==n){
for(int i=0;i<n;i++){
System.out.print(res[i]+" ");
}
System.out.println();
return;
}
for(int i=1;i<=n;i++){
if(!used[i]){
res[u]=i;
used[i]=true;
dfs(u+1);
used[i]=false;
}
}
}
}