7-3 Telefraud Detection (25分)
Telefraud(电信诈骗) remains a common and persistent problem in our society. In some cases, unsuspecting victims lose their entire life savings. To stop this crime, you are supposed to write a program to detect those suspects from a huge amount of phone call records.
A person must be detected as a suspect if he/she makes more than K short phone calls to different people everyday, but no more than 20% of these people would call back. And more, if two suspects are calling each other, we say they might belong to the same gang. A makes a short phone call to B means that the total duration of the calls from A to B is no more than 5 minutes.
Input Specification:
Each input file contains one test case. For each case, the first line gives 3 positive integers K (≤500, the threshold(阈值) of the amount of short phone calls), N (≤10^3,the number of different phone numbers), and M (≤10^5, the number of phone call records). Then M lines of one day’s records are given, each in the format:
caller receiver duration
where caller and receiver are numbered from 1 to N, and duration is no more than 1440 minutes in a day.
Output Specification:
Print in each line all the detected suspects in a gang, in ascending order of their numbers. The gangs are printed in ascending order of their first members. The numbers in a line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.
If no one is detected, output None instead.
Sample Input 1:
5 15 31
1 4 2
1 5 2
1 5 4
1 7 5
1 8 3
1 9 1
1 6 5
1 15 2
1 15 5
3 2 2
3 5 15
3 13 1
3 12 1
3 14 1
3 10 2
3 11 5
5 2 1
5 3 10
5 1 1
5 7 2
5 6 1
5 13 4
5 15 1
11 10 5
12 14 1
6 1 1
6 9 2
6 10 5
6 11 2
6 12 1
6 13 1
Sample Output 1:
3 5
6
Note: In sample 1, although 1 had 9 records, but there were 7 distinct receivers, among which 5 and 15 both had conversations lasted more than 5 minutes in total. Hence 1 had made 5 short phone calls and didn’t exceed the threshold 5, and therefore is not a suspect.
Sample Input 2:
5 7 8
1 2 1
1 3 1
1 4 1
1 5 1
1 6 1
1 7 1
2 1 1
3 1 1
Sample Output 2:
None
#include <iostream>
#include <vector>
#include <algorithm>
#include <unordered_map>
using namespace std;
const int N = 1e3 + 10;
int g[N][N], p[N];
int k, n, m;
int find (int x)
{
if(p[x] != x) return p[x] = find(p[x]);
return p[x];
}
int main()
{
cin >> k >> n >> m;
while(m --)
{
int id, son, time;
cin >> id >> son >> time;
g[id][son] += time;
}
vector <int> h;
for(int i = 1; i <= n; i ++)
{
int in = 0, back = 0;
for(int j = 1; j <= n; j ++)
{
if(g[i][j] && g[i][j] <= 5)
{
in ++;
if(g[j][i]) back ++;
}
}
if((double) back / in <= 0.2 && in > k) h.push_back(i);
}
if(h.empty()) puts("None");
else{
for(auto i : h) p[i] = i;
for(int i = 0; i < h.size(); i ++)
for(int j = 0; j < i; j ++)
if(g[h[i]][h[j]] && g[h[j]][h[i]]) p[find(h[i])] = find(h[j]);
unordered_map <int, vector <int> > tmp;
for(auto i : h) tmp[find(i)].push_back(i);
vector <vector <int> > info;
for(auto i : tmp) info.push_back(i.second);
sort(info.begin(), info.end());
for(auto i : info)
{
cout << i[0];
for(int j = 1; j < i.size(); j ++) cout << " " << i[j];
puts("");
}
}
return 0;
}
第一次见vector[HTML_REMOVED]> vc里面可以排序
大佬厉害
大佬tql,这题快把我整吐了QAQ。改了一个小时结果是计算总时间 哭了